Degraded performance on SaaS US

Incident Report for Incode

Resolved

A fix was implemented and the degradation was resolved.
Posted May 11, 2026 - 22:30 UTC

Update

Our team continues investigating, corrective measures were taken and there should be an improvement in the transaction success rate. We will provide additional information soon
Posted May 11, 2026 - 22:11 UTC

Investigating

We have detected a degradation affecting SaaS US environment, our internal team is investigating. We will provide additional information soon.
Posted May 11, 2026 - 21:55 UTC
This incident affected: Incode Omni (Omni US).