All systems are operating normally. Confirmation received from Vendor that all services have fully recovered
Posted May 09, 2026 - 03:52 UTC
Update
All systems are operating normally, but we’re still seeing intermittent issues affecting some services. We’re awaiting confirmation from provider that all services have fully recovered.
Posted May 08, 2026 - 23:33 UTC
Update
We are continuing to monitor for any further issues.
Posted May 08, 2026 - 20:29 UTC
Update
All systems are operating normally, but we’re still seeing intermittent issues affecting some services. We’re awaiting confirmation from provider that all services have fully recovered.
Posted May 08, 2026 - 17:01 UTC
Update
All systems are operating normally, but we’re still waiting for the provider to confirm that all services have fully recovered.
Posted May 08, 2026 - 15:01 UTC
Update
The cloud provider updates look promising, but they still haven't closed out the incident. We are still observing the situation.
Posted May 08, 2026 - 09:21 UTC
Update
The SaaS US platform continues to be stable without further degradation. We are still in close observation mode, since the cloud provider hasn't confirmed complete restoration of the affected availability zone.
Posted May 08, 2026 - 06:27 UTC
Monitoring
We detect an important improvement in the service levels. There was no need to switch to a secondary region. Our team continues monitoring.
Posted May 08, 2026 - 06:04 UTC
Investigating
We are currently detecting a degradation caused by our public cloud provider, we are activating a failover to a secondary region.