SaaS US - Increased latency

Incident Report for Incode

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 18:31 UTC

Monitoring

We are seeing signs of recovery, latency levels going back to normal.
Posted Jul 27, 2026 - 18:04 UTC

Investigating

We are currently investigating the issue
Posted Jul 27, 2026 - 17:58 UTC
This incident affected: Incode Omni (Omni US).